在FireFox3中使用不兼容的插件

FireFox3正式发布了,其实从beta4开始就从FireFox2换成3了。在内存使用和浏览速度方面,FireFox3确实改进不少。不过有些插件一直不更新,比如Gladder等,导致在 FireFox3中由于不兼容而不能使用,有点烦人。不过这个兼容性检查,其实只是check了一下插件的兼容版本号,大部分旧版本的插件,其功能在 FireFox3其实还是可以使用的。那么就有两个办法来绕过这个兼容性检查,一是修改插件的可以支持的版本号,二是设置FireFox3不执行插件兼容性检查。

一、修改插件
首先将插件下载到本地。FireFox的插件扩展名是xpi,其实是一个zip压缩打包文件,用winrar等可以打开。找到里面的install.rdf文件,可以找到如下内容:

<em:targetApplication>
<Description>
<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
<em:minVersion>1.5</em:minVersion>
<em:maxVersion>3.0b3pre</em:maxVersion>
</Description>
</em:targetApplication>

发现了没(通过rss阅读的朋友可能看不到上面的代码,请移步到这里),minVersionmaxVersion就定义了该插件可以支持的FireFox版本,将3.0b3pre改成3.0,保存后重新安装插件即可。嗯,怎么修改?把install.rdf拖出来整完再拖回去;怎么重新安装?再把xpi拖进FireFox,搞定收工。

二、设置FireFox
在FireFox3地址栏输入about:config,出来一个警告页面,不理他,”我保证我会小心”。然后点右键,选择”新建”->”布尔”,创建一个布尔变量extensions.checkCompatibility,值为false,表示不检查扩展插件的兼容性。同样的步骤再创建一个布尔变量extensions.checkUpdateSecurity,值为false,不检查安全更新。重启,搞定。



发表评论

电子邮件地址不会被公开。 必填项已用*标注

− 1 = 1