Lazarus 嵌入汇编脚本时遇到 selected assembler reader not supported 错误的解决办法

正在迁移一个vcl组件到Lazarus,其中涉及到了一些汇编代码,在编译的时候报了这么个错误

Fatal: selected assembler reader not supported

莫名奇妙的问题,网上google了一下,貌似这是Lazarus的问题。解决办法也容易,加一句编译指令
就ok了。

{$ASMMODE intel}

这个编译指令可以放在单元的首部,也可以加在工程设置里,也可以写在一个Inc文件里,再用{$I} 指令导入。

改完之后再编译就没问题了。



发表评论

电子邮件地址不会被公开。 必填项已用*标注

79 − = 73